Change font size
It is currently Sun Oct 22, 2017 10:21 am


Post a new topicPost a reply Page 1 of 1   [ 2 posts ]
Author Message
 Post subject: BVH for 3ds Max CAT rig
PostPosted: Tue Jul 14, 2015 2:09 am 

Joined: Tue Jul 14, 2015 1:34 am
Posts: 6
I am trying to apply a BVH motion capture file to a 3ds Max CAT rig and can't get it to work. I have seen several posts and videos on how to do it, but none of them works for me. Applying the bvh file first to a Biped, and then the BIP file to the CAT rig doesn't work. I also found a post that tells me to use Biped twice, first BVH on Biped and export as BIP, then BIP on Biped and export again and then BIP on CAT, but no luck. In one of the posts there was a .cam file with a maping, so I tried that, also no luck.

But all the posts that I found are over 2 years old, so I can imagine things have changed in MAX and perhaps also in the BVH export.

The main problem is that bones are rotated, for example the toes and the shoulders/arms, which results in that the hands of the character and the handbones of the skeleton are not correct. And when I rotate them 180 degrees to get the proper rotation for the CAT rig the animation is screwed up. I did clear the mapping first, then rotate the bones in the source hierarchy and then do automapping again, but that also didn't solve the problem

Attached are some screenshots. The first is of the rig itself, in T-pose palms facing down. Then there are screenshots with BVH import, where you can see that now the palms of the character are facing up, although the palm of the skeleton is facing down. And of the BIP import, same problem.

I hope someone can tell me how to fix this or send me a .cam file with the correct mapping.

Thanks!


Attachments:
CAT rig without motion capture.jpg
CAT rig without motion capture.jpg [ 137.95 KiB | Viewed 3444 times ]
CAT rig with BVH mocap.jpg
CAT rig with BVH mocap.jpg [ 126.62 KiB | Viewed 3444 times ]
CAT rig with BIP mocap-1.jpg
CAT rig with BIP mocap-1.jpg [ 254.33 KiB | Viewed 3444 times ]
Top
 Profile  
 
PostPosted: Tue Aug 25, 2015 5:51 am 

Joined: Thu Sep 04, 2014 9:47 am
Posts: 718
Location: Florida USA
...

In case you haven't figured this out yet...

When you add your .bip file you should scale the biped to better match your character, it's too tall as it is on the screenshot, this is located in the info window when you select add motion capture file from the layer manager of the CAT roll-outs, you know where it is because you made it to the mapping window.

You may need to adjust this a few times to get it right by just adding the motion file again, adjusting the biped height down more, then delete the other wrong scaled biped, by selecting any bone on the old one and hit delete key, easiest way. (careful not to delete the wrong biped).

If any bones come in 180 rotated, they may or may not, but don't worry it happens, just carry on and fix it after you capture the motion to your CAT rig character.

I see in the screenshot the mapping is still red, means you didn't click the button for source object and hit auto-map, then click the button for Base Human 001, (or whatever you named your CAT rig), and hit auto-map again, red line will disappear, or should now, and rig should be properly mapped.

Then click Capture, when it's finished delete the source when prompted, your animation should be baked to your CAT character now.

Then, if arms are still rotated wrong, go to first frame (0) and rotate them correctly, they should now maintain this rotation to match the animation, you can do that with any bone rotations you feel are off.

There is an issue that may happen with the feet, and probably will, where you have to go into the limb animation roll-out, select the IK for the foot in the scene and click (select limb end), then rotate it to be flat with the floor and IK controller, if this puts the rig off the floor, as it will, click the 4-green arrows (layer transform gizmo) in the layer manager section, click on the root node in the scene, (box between the feet), and select move tool and position it correctly, then untick the layer gizmo.

Your animation should then work fine, if not, you need to try again, until you get the process down, it will take a few attempts, just how it is, I know it should be easier, but I haven't found a way yet, you will get more familiar with it as you do it more.

You can also just add the BVH file the same way, but it will bring in a stick figure instead of a biped, do scale the same way, but works in a bit different way for adjusting things, a bit more involved, so using a BIP file is probably better.

Hope this helps.

...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 2 posts ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB® Forum Software © phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net