Change font size
It is currently Mon Dec 16, 2019 3:31 am


Post a new topicPost a reply Page 1 of 2   [ 17 posts ]
Go to page 1, 2  Next
Author Message
 Post subject: Troubleshooting tracking
PostPosted: Sat Aug 21, 2010 7:14 am 

Joined: Fri Jul 09, 2010 5:46 am
Posts: 37
Location: France
Hi all,

Finally been able to record a decent mocap session. This time calibration was perfect. I'm just beginning to analyze the data and I'm sure I'll run into some troubles. But first...

I have a little session where the actor just walks through the capture volume. Except one of the arms that goes crazy in the last frames (my cams aren't perfectly placed, I suppose it's partially occluded), eveything is good. But when playing back the animation, the legs, although being correctly tracked, are really trembling a lot. As I don't want an epileptic motion (lol), how do I smooth it ? I applied Jitter Removal but it did'nt seem to have any effect.


Top
 Profile  
 
PostPosted: Tue Aug 24, 2010 1:46 am 

Joined: Fri Jul 09, 2010 5:46 am
Posts: 37
Location: France
No one ? At least, can you people tell me if you have to smooth the animation after mocap ? And does Jitter removal works for you ?


Top
 Profile  
 
PostPosted: Tue Aug 24, 2010 8:35 am 
iPi Soft

Joined: Wed Apr 07, 2010 4:33 am
Posts: 379
Hello!

As a rule slight smoothing plus Jitter Removal works fine. Please, check the following:
  • Value in "Post-processing: Trajectory Filtering" is 1 or 2
  • Region of Interest (aka ROI) is set correctly during applying of Jitter Removal
  • Jitter Removal has finished its work completely (there are two phases: preparation and frame-by-frame calculation like tracking but several times faster)

If you still have problems, could you please send to us problematic MoCap project (in this case it is enough to send only *.MoCap file because problems are not in tracking).


Top
 Profile  
 
PostPosted: Tue Aug 24, 2010 10:58 am 

Joined: Mon Aug 03, 2009 1:34 pm
Posts: 2363
Location: Los Angeles
Earlack wrote:
No one ? At least, can you people tell me if you have to smooth the animation after mocap ? And does Jitter removal works for you ?


Sorry, I almost replied to your first post, but my only suggestion would have been to enable Jitter Removal, which it sounds like you tried.

FWIW, Jitter Removal fixes the trembling feet problem for me every time. Because you're still having problems with jitter, I was wondering how clear the feet are in your video footage. For example, if your performer is wearing dark shoes and there are dark shadows cast on them or the ground is also dark, the motion tracker may get confused about the shape and rotation of the feet. If that's the case, I suggest wearing lighter shoes or socks. (FYI, I wear white socks because they stand out clearly even in shadow; so far this seems to work well for me.)

Hope this helps.

G.

_________________
Greenlaw
Artist/Partner - Little Green Dog | Demo Reel (2017) | Demo Reel (2015) | Demo Reel (2013)

Image
Watch a one minute excerpt on Vimeo now!


Top
 Profile  
 
PostPosted: Tue Aug 24, 2010 11:20 am 

Joined: Fri Jul 09, 2010 5:46 am
Posts: 37
Location: France
Thanks Greenlaw,

well it is the same background and actor as seen in this topic :
http://ipisoft.com/forum/viewtopic.php?f=5&t=4269&p=5634&sid=b5b88a594bd081246097f8819ca3f0d0&sid=b5b88a594bd081246097f8819ca3f0d0#p5634

The shadows don't seem hard and dark, but the shoes and the jeans have somewhat similar colors. I'm retrying a jitter removal right now. Is it normal during jitter removal process, if the smoothing value turns to zero ? Maybe not related but just spotted this. I'll update the post in a few minutes.

EDIT : still no luck. I opened my project, clicked on "Apply" below Jitter Removal. It calculated, as described by Andrew, but... Result is the same. Absolutely no change.


Top
 Profile  
 
PostPosted: Tue Aug 24, 2010 12:13 pm 
iPi Soft

Joined: Wed Apr 07, 2010 4:33 am
Posts: 379
Please, send your *.MoCap file to ipi@ipisoft.com.


Top
 Profile  
 
PostPosted: Tue Aug 24, 2010 12:47 pm 

Joined: Fri Jul 09, 2010 5:46 am
Posts: 37
Location: France
Sent !


Top
 Profile  
 
PostPosted: Tue Aug 24, 2010 2:25 pm 
iPi Soft

Joined: Wed Apr 07, 2010 4:33 am
Posts: 379
Wow!
It is not post-processing problem. It is tracking problem! Build-in post-processing cann't eliminate such vast oscillations of essentially the entire lower body. Could you share source video, please?


Top
 Profile  
 
PostPosted: Wed Aug 25, 2010 2:15 am 

Joined: Fri Jul 09, 2010 5:46 am
Posts: 37
Location: France
Quote:
Wow!


As you say ! :)

Quote:
Could you share source video, please ?


Ok, but it's a 1 GB file, how do I send it... ? As it's RAW PS3, I don't know if I can easily cut it without too much loss.


Top
 Profile  
 
PostPosted: Wed Aug 25, 2010 2:35 am 
iPi Soft

Joined: Wed Apr 07, 2010 4:33 am
Posts: 379
Earlack wrote:
Quote:
Wow!
Ok, but it's a 1 GB file, how do I send it... ? As it's RAW PS3, I don't know if I can easily cut it without too much loss.


You can use one of the services for sharing large files. For example:


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 2   [ 17 posts ]
Go to page 1, 2  Next


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron


Powered by phpBB® Forum Software © phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net