Change font size
It is currently Fri Nov 17, 2017 11:22 pm


Post a new topicPost a reply Page 1 of 1   [ 10 posts ]
Author Message
 Post subject: Kinect V2 Frame drops
PostPosted: Mon May 16, 2016 8:22 am 

Joined: Mon Apr 25, 2016 6:46 am
Posts: 4
Hi !
In ipi Recorder statistics are red and framerate is below 30fps, while it works perfectly in Kinect Studio v2.
CPU: i5 2500k
GPU: Nvidia Geforce GTX 970
RAM: 16GB DDR3

any ideas ?


Top
 Profile  
 
PostPosted: Mon May 16, 2016 9:25 am 

Joined: Mon Apr 25, 2016 6:46 am
Posts: 4
Alright I just found a solution.
Keeping Kinect Studio 2 in the background improves framerate to 29.6 fps.


Top
 Profile  
 
PostPosted: Sat Sep 10, 2016 11:33 pm 

Joined: Sat Sep 10, 2016 3:07 am
Posts: 1
Doctor_GLaDOS wrote:
Alright I just found a solution.
Keeping Kinect Studio 2 in the background improves framerate to 29.6 fps.


I tried this and my fps went down slightly. :-(

_________________
Just buy this it works.


Top
 Profile  
 
PostPosted: Sat Feb 04, 2017 11:45 pm 

Joined: Wed Jan 25, 2017 2:07 am
Posts: 2
I've got a similar problem - low framerate, on a very high spec laptop with the latest Kinect sensor. Anyone else got any ideas?


Top
 Profile  
 
PostPosted: Sat Feb 11, 2017 4:28 pm 

Joined: Wed Jan 25, 2017 2:07 am
Posts: 2
I have a similar problem. Have 3x Kinect 2 depth sensor configuration. 2 of the depth sensors are on lower spec hardware, yet they have no problems maintaining a close to 30fps frame rate. One of the 3 sensors is running on a new Alienware R4 i7 16GB RAM, PCI-SSD, GeForce 1060 laptop, and it sometimes struggles to achieve 25fps. Sometimes a clean reboot and having absolutely no other apps running helps, sometimes not. Not clear to me where the bottleneck is. Any suggestions welcome.


Top
 Profile  
 
PostPosted: Fri Feb 17, 2017 5:20 am 
iPi Soft

Joined: Wed Jan 11, 2012 6:12 am
Posts: 1934
Location: Moscow, Russia
Does it have a built-in Intel graphics in addition to GeForce 1060? Try disabling either one of GPUs completely.


Top
 Profile  
 
PostPosted: Sun Feb 19, 2017 4:08 pm 

Joined: Fri Nov 11, 2016 6:25 pm
Posts: 2
I'm having the same issue with Kinect 2 on a 2016 MacBook Pro (running Win10 in Bootcamp). My iPi Recorder either records at a incredibly low framerate (under 5 FPS) or straight-up crashes at the first movement. The system specs are:

- 2.6GHz quad-core Intel Core i7
- 16GB RAM
- Radeon Pro 460 with 4GB RAM
- Windows 10 (Configured to focus on high performance...but there's always a chance I missed a setting.)

This is especially odd as I previously used iPi Recorder on a 2012 MacBook Pro running Windows 10 and experienced no performance issues. Here's a sample: https://www.youtube.com/watch?v=JY5oxu0wnvU

So, the only other thing that's changed besides the laptop specs is I'm using a USB to USB-C adaptor for the Kinect 2. However, I recorded video with Kinect Studio 2.0 and the framerate is a solid 30 FPS.

I'm at a complete loss for why my performance has taken such a significant turn for the worse compared to 4-year old hardware.

Any advice would be appreciated.


Top
 Profile  
 
PostPosted: Mon Feb 20, 2017 1:12 am 
iPi Soft

Joined: Wed Jan 11, 2012 6:12 am
Posts: 1934
Location: Moscow, Russia
I would say Kinect has hard times with the USB 3.1 controller in your new MacBook. However, if you claim it works like a charm in Kinect Studio, then I'm lost.
BTW how do you know the FPS in Kinect Studio? AFAIK it is not shown anywhere.


Top
 Profile  
 
PostPosted: Mon Apr 03, 2017 7:48 pm 

Joined: Wed Mar 22, 2017 12:26 pm
Posts: 13
vmaslov wrote:
I would say Kinect has hard times with the USB 3.1 controller in your new MacBook. However, if you claim it works like a charm in Kinect Studio, then I'm lost.
BTW how do you know the FPS in Kinect Studio? AFAIK it is not shown anywhere.


FPS counter shows up if it's below normal.


Top
 Profile  
 
PostPosted: Fri Jun 16, 2017 2:19 am 

Joined: Mon Apr 25, 2016 6:46 am
Posts: 4
Not to be overly dramatic but after many many[MANY] hours of throwing myself at the wall I might have finally found the solution.
After disabling Pagefile my framerate went from around 25 to solid 30.
Here is a tutorial: http://tunecomp.net/win10-page-file-disable/

Can I have a cookie now?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 10 posts ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB® Forum Software © phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net