ipisoft.com
http://forum.ipisoft.com/

Kinect V2 Frame drops
http://forum.ipisoft.com/viewtopic.php?f=5&t=9570
Page 3 of 4

Author:  RichardHernandez [ Sat May 25, 2019 2:29 pm ]
Post subject:  Re: Kinect V2 Frame drops

kanakas wrote:
I've got a similar problem - low framerate, on a very high spec laptop with the latest Kinect sensor. Anyone else got any ideas?


the skeletal data of the subject using the depth stream however, its frame rate is only around 5-7 fps.

Author:  vmaslov [ Tue May 28, 2019 1:56 am ]
Post subject:  Re: Kinect V2 Frame drops

Have you tried all available USB ports for connecting Kinect?

Author:  bluebox [ Tue May 28, 2019 3:12 am ]
Post subject:  Re: Kinect V2 Frame drops

multi kinect2.0 the frames of sensor about 15fps when use the
Attachment:
QQ图片20190528180704.png
QQ图片20190528180704.png [ 1.69 KiB | Viewed 4115 times ]
driver

Author:  MarcusSmith [ Mon Jun 24, 2019 2:12 pm ]
Post subject:  Re: Kinect V2 Frame drops

kanaka wrote:
I have a similar problem. Have 3x Kinect 2 depth sensor configuration. 2 of the depth sensors are on lower spec hardware, yet they have no problems maintaining a close to 30fps frame rate. One of the 3 sensors is running on a new Alienware R4 i7 16GB RAM, PCI-SSD, GeForce 1060 laptop, and it sometimes struggles to achieve 25fps. Sometimes a clean reboot and having absolutely no other apps running helps, sometimes not. Not clear to me where the bottleneck is. Any suggestions welcome.


I have also faced this problem where one of the 3 sensors were running on a new Alienware R4 i7 16GB RAM, PCI-SSD, GeForce 1060 laptop, and many times it used to struggles to achieve 25fps. Don't know why. Any reason .

Author:  vmaslov [ Wed Jun 26, 2019 6:20 am ]
Post subject:  Re: Kinect V2 Frame drops

Some suggestions
  • Try all available USB ports.
  • Ensure both iPi Recorder app and KinectService.exe process are running with discrete GPU.
  • Try disabling swap file.
  • Try using libfreenect2 instead of Kinect SDK.

Author:  MarcusSmith [ Mon Jul 01, 2019 10:56 am ]
Post subject:  Re: Kinect V2 Frame drops

kanaka wrote:
I have a similar problem. Have 3x Kinect 2 depth sensor configuration. 2 of the depth sensors are on lower spec hardware, yet they have no problems maintaining a close to 30fps frame rate. One of the 3 sensors is running on a new Alienware R4 i7 16GB RAM, PCI-SSD, GeForce 1060 laptop, and it sometimes struggles to achieve 25fps. Sometimes a clean reboot and having absolutely no other apps running helps, sometimes not. Not clear to me where the bottleneck is. Any suggestions welcome.


Even I have got a similar problem - low framerate, also on very high spec laptop with the latest Kinect sensor. Any update on this .

Author:  AlanBarefield [ Wed Jul 03, 2019 3:30 pm ]
Post subject:  Re: Kinect V2 Frame drops

kanakars wrote:
I've got a similar problem - low framerate, on a very high spec laptop with the latest Kinect sensor. Anyone else got any ideas?


I need to track the skeletal data of the subject using the depth stream however, its frame rate is only around 5-7 fps.

Author:  vmaslov [ Thu Jul 04, 2019 10:04 am ]
Post subject:  Re: Kinect V2 Frame drops

Have you tried suggestions from my above post?

Author:  lanaroady [ Thu Jul 18, 2019 3:41 am ]
Post subject:  Re: Kinect V2 Frame drops

SteveJohnson wrote:
vmaslov wrote:
Hi
Maybe you've already tried all that I suggest below, but check:
  • Set power plan to High Performance
  • Try all USB ports available to connect Kinect
  • Check this particular Kinect with another PC (master?) to ensure it's not the sensor fault
  • Update graphics drivers, both for discrete and integrated graphics
  • Disable one of the graphic cards completely in Device Manager
  • Disable swap file as mentioned previously in this topic


Thank you so much for your help. I was so much frustrated that framerate was not going over 25. I think disabling the swap file solved my problem.


All of these stick to the frustated frame work which are not connected to those kinect :(

Author:  FredReiss [ Tue Jul 30, 2019 10:47 am ]
Post subject:  Re: Kinect V2 Frame drops

MarcusSmith wrote:
kanaka wrote:
I have a similar problem. Have 3x Kinect 2 depth sensor configuration. 2 of the depth sensors are on lower spec hardware, yet they have no problems maintaining a close to 30fps frame rate. One of the 3 sensors is running on a new Alienware R4 i7 16GB RAM, PCI-SSD, GeForce 1060 laptop, and it sometimes struggles to achieve 25fps. Sometimes a clean reboot and having absolutely no other apps running helps, sometimes not. Not clear to me where the bottleneck is. Any suggestions welcome.


I have also faced this problem where one of the 3 sensors were running on a new Alienware R4 i7 16GB RAM, PCI-SSD, GeForce 1060 laptop, and many times it used to struggles to achieve 25fps. Don't know why. Any reason .


I have also faced the same problem and I am not getting the solution of it.

Page 3 of 4 All times are UTC - 8 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/