Change font size
It is currently Fri Nov 17, 2017 11:22 pm


Post a new topicPost a reply Page 1 of 1   [ 6 posts ]
Author Message
 Post subject: Ground Detection Issue
PostPosted: Mon Apr 24, 2017 2:04 pm 

Joined: Tue Feb 28, 2017 4:18 pm
Posts: 8
Hi,

I'm struggling with calibration of the system and can't get the ground to detect at the appropriate height.

- I have a 16 camera setup with cameras at varying heights, when I run through calibration all cameras are "perfect". However when I record the ground floor is at the actors knees.
- I tried to adjust ground height in iPiStudio UI, but this doesn't allow for enough adjustment to compensate for the error.
- I've also tried to manually calibrate ground. I cleared all ground points and then manually marked each ground corner and ground middle.
- I've put cardboard on all the windows so no natural light is not getting in.
- I've also tried countless calibration patterns with the mag light.

Unfortunately I'm unable to get the ground height to work.

Thanks in advance for the help.


Top
 Profile  
 
PostPosted: Mon Apr 24, 2017 4:16 pm 

Joined: Mon Aug 03, 2009 1:34 pm
Posts: 2229
Location: Los Angeles
I was wondering: is the floor shiny and reflective? If there are moving reflections, that might through off calibration, especially with the flashlight. If that's the case, you might through a rug or a non-shiny drop cloth over the floor.

Same holds true for walls, windows, etc.

Many years ago, I recall a computer screen in the background running a screen saver messed up my calibration. That was with the old Logitech cameras but it might still happen with PS3 Eye.

The only other thing I can think of is camera positions. If you're not already doing so, try staggering the height and positions of the cameras. It doesn't help when all the cameras are the same height and angle.

_________________
Greenlaw
Artist/Partner - Little Green Dog | Demo Reel (2017) | Demo Reel (2015) | Demo Reel (2013)

Image
Watch a one minute excerpt on Vimeo now!


Top
 Profile  
 
PostPosted: Tue Apr 25, 2017 1:35 am 
iPi Soft

Joined: Wed Jan 11, 2012 6:12 am
Posts: 1934
Location: Moscow, Russia
Hi
I do not understand from your description whether the problem appears in the calibration project itself (i.e. the floor plane is put far away from ground marks) or only in action projects when you apply a scene file. Can you share one calibration and one action video via Google Drive, Dropbox, or similar service?


Top
 Profile  
 
PostPosted: Tue Apr 25, 2017 2:52 pm 

Joined: Thu Sep 04, 2014 9:47 am
Posts: 736
Location: Florida USA
...

Are you setting correct cam 1 height off floor, before saving the scene file? This has to be the camera set as camera 1 in the recorder view port.

You state when you record the floor grid is at actors knees, do you mean once you bring it into iPi Studio instead? Because there is no floor grid in the recorder when recording.

...


Top
 Profile  
 
PostPosted: Tue Apr 25, 2017 8:57 pm 

Joined: Tue Feb 28, 2017 4:18 pm
Posts: 8
Yes, it was in iPi studio where the ground floor appeared to be higher than the actor. I did solve the problem today after adjusting certain camera heights and changing the camera 1 height.

Thanks for the help.


Top
 Profile  
 
PostPosted: Wed Apr 26, 2017 5:01 am 

Joined: Thu Sep 04, 2014 9:47 am
Posts: 736
Location: Florida USA
...

Great!

I have read where 16 cameras can be a bit of a task to calibrate easily and consistently, although I have never attempted it yet.

One thing you should do is don't turn off the standard room lighting, just use the camera darkening options, but it is better to turn off any extra lights, or glowing objects that would be in the trajectory of your light cage, as stated above by Greenlaw, or the iPi tracker may jump and lock on to those and ruin your calibration attempt, and you won't know this until you actually run the calibration in the Studio.

Also, it is better to have the lowest number of misdetects possible, this number optimally would be below 1% and very close to same number on all cameras, even though iPi Docs states it can be up to 10%, I find that to be too high of an error rate for best results in tracking, as it causes cameras with higher error rates to not align as well as they should on refit, just my personal opinion over the many times I have calibrated my 6 camera set up and tried tracking with many different calibration video results.

Now I know exactly what my calibration readings should be and if they are off, I know something didn't go as well as possible and I re-do the light tracking video again.

Always best to do a second calibration phase after any full session also, that way you have a second choice just in case a camera got inadvertently moved, even slightly.

You must be using a fairly large area to be using 16 cameras, or are you using a several high, several level and several low set up on a smaller capture volume?
Just wondering.

I would like to ask if you would post a YouTube video link in this thread of your tracking results once you get things working well?

Good Luck!

...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 6 posts ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB® Forum Software © phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net