Change font size
It is currently Mon Nov 19, 2018 5:10 am


Post a new topicPost a reply Page 1 of 1   [ 4 posts ]
Author Message
PostPosted: Mon Oct 15, 2018 3:37 am 

Joined: Fri Oct 05, 2018 10:37 am
Posts: 4
Hi,

I'm after some advice on light marker calibration. I've been trying for days to get a good calibration, but it either fails or it's not good enough, so I was hoping for some advice.

Please see the screenshot attached, which explains my problem. I'm using 2 Kinect v2s. As you can see, I'm using a black background, I'm wearing black clothes, and the lighting in the room is dim. However, as you can see in the screenshot, Mocap Studio keeps picking up random locations - you can see that on the left hand side of the screenshot, there are a lot of green markers (I assume this is Mocap Studio detecting the light marker), which are all false readings. However those areas are all very dark, especially in comparison with the very distinctive bright light form the marker. Also, the light marker itself does not get picked up very well. I don't understand what I'm doing wrong, and I can't think of anything else I can do to get a good "signal" to Mocap Studio. I've also tried running the calibration using 'small', 'medium' and 'large' for the marker size. Does anyone have any suggestions?

Many thanks for any help!

James


Attachments:
File comment: Screenshot
Capture.PNG
Capture.PNG [ 699.13 KiB | Viewed 108 times ]
Top
 Profile  
 
PostPosted: Mon Oct 15, 2018 4:00 am 
iPi Soft

Joined: Wed Jan 11, 2012 6:12 am
Posts: 2039
Location: Moscow, Russia
Hi
These green particles display detected trajectory of the marker in time. Probably, those false ones have been detected when the actual marker was obscured by your body. To get good calibration results you should try to keep the marker always visible to both cameras simultaneously. And motion range of the marker throughout a video should cover most of intended capture volume.
If you share your video file this may help to identify your problems.


Top
 Profile  
 
PostPosted: Mon Oct 15, 2018 5:03 am 

Joined: Fri Oct 05, 2018 10:37 am
Posts: 4
I've figured out what I was doing wrong. Hopefully this might help others with the same issue:

The Maglight torch I'm using is shiny metal silver. You can see in the original screenshot that I was holding it near the end, which left the body of the torch exposed. I tried it again, this time holding the torch in my fist, with only the bulb visible (see second screenshot) - this simple change gave MUCH better results!


Attachments:
File comment: Results when holding torch this way
Capture2.PNG
Capture2.PNG [ 500.05 KiB | Viewed 102 times ]
File comment: Second screenshot - this helped a lot
IMG_20181015_125554.jpg
IMG_20181015_125554.jpg [ 178.42 KiB | Viewed 102 times ]
Top
 Profile  
 
PostPosted: Mon Oct 15, 2018 4:09 pm 

Joined: Mon Aug 03, 2009 1:34 pm
Posts: 2292
Location: Los Angeles
Ah, that makes sense. The one I use is all black with a matte finish. Never had an issue with it.

Alternatively, the lighted sphere on a PS Move controller works well too.

_________________
Greenlaw
Artist/Partner - Little Green Dog | Demo Reel (2017) | Demo Reel (2015) | Demo Reel (2013)

Image
Watch a one minute excerpt on Vimeo now!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 4 posts ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB® Forum Software © phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net