ipisoft.com
http://forum.ipisoft.com/

Kinect 2 camera not working, Help appreciated
http://forum.ipisoft.com/viewtopic.php?f=7&t=9670
Page 1 of 3

Author:  SecondHarvest [ Sat Nov 26, 2016 6:59 am ]
Post subject:  Kinect 2 camera not working, Help appreciated

So, I have been trying to set up my kinect 2 camera on a new windows 10 computer I recently build, and upon running the kinect configuration verifier, it claims that there are no USB 3.0 ports installed.
My device manager disagrees, I should have 4 blue usb installed.

Am I missing something stupid? I have a conflic on the kinect camera, I assume because it;s not finding it correctly from the USB I plug it into. The camera works fine on my 6 yr old laptop, so it should work with a brand new build.

See attached screenshots

Attachments:
Untitled-3.jpg
Untitled-3.jpg [ 71.13 KiB | Viewed 7724 times ]
Untitled-2.jpg
Untitled-2.jpg [ 121.84 KiB | Viewed 7724 times ]
Untitled-1.jpg
Untitled-1.jpg [ 103.36 KiB | Viewed 7724 times ]

Author:  vmaslov [ Mon Nov 28, 2016 3:06 am ]
Post subject:  Re: Kinect 2 camera not working, Help appreciated

Hi
As you can see in system requirements, Microsoft recommends Intel or Renesas (NEC) USB 3.0 controllers. From the screenshot I see that your PC has got ASMedia USB 3.0 controller, which may be incompatible with Kinect v2.
Have you tried all available USB 3.0 ports to connect Kinect sensor?
Have you tried to disconnect all high-bandwidth USB devices before connecting Kinect sensor?
Also, check the Troubleshooting section for Kinect v2. Maybe you'll find something helpful there.

Author:  SecondHarvest [ Mon Nov 28, 2016 3:40 am ]
Post subject:  Re: Kinect 2 camera not working, Help appreciated

Thanks, since posting this, I have installed a seperate Microsoft usb card, and rolled back to windows 8.1
I actually managed to see the kinect working for 0 frames a second, but then it constantly looks like it is installing it over and over. I hear the sound for installing new hardware, then it updates the buffer picture.
I can at least now start ipirecorder with kinect camera, but it stays black screen.

I should add, the cameras I have both work fine on my laptop.

I check out the suggestions you mentioned, thanks

Author:  Greenlaw [ Mon Nov 28, 2016 1:50 pm ]
Post subject:  Re: Kinect 2 camera not working, Help appreciated

You might not be able to get it to work with a six year old computer.

Over a year ago, I tried to use the computers on our render farm, all--i7 quad cores but about 5 - 6 years old--to support four Kinect One sensors with iPi Recorder. I tried various USB 3.0 cards that should have been compatible but I could never get a satisfactory frame rate from these render boxes.

Of all our 'older' computers, only my six-year old i7 workstation is able to sufficiently capture Kinect 2.0. And even though it works fine, it does seem to struggle a little to maintain the maximum rate.

By contrast, my small Windows 10 tablet, which is about 1 1/2 years old, supports a Kinect One on our network much better than my old workstation. That's right...a tablet computer!

IMO, you may need to look into getting a newer computer with a modern and more efficient motherboard and processor. Tip: Make sure the new computer has at least an i7 processor with a compatible USB controller and graphics card--the more power, the better. We recently got a laptop for my daughter and it almost supports Kinect but unfortunately the framerate fluctuates between 30 fps and 26 fps, making it unsuitable. I think this is because it's an i5 processor. Looking back, I really wish I had spent just a little more for the better processor because my daughter was eager to add her laptop to the mocap network. :)

Now I'm thinking of getting a new computer next year but that won't be happening any time soon. Until then, fortunately, I have two Windows 10 computers that do support Kinect One.

Author:  SecondHarvest [ Tue Nov 29, 2016 4:26 am ]
Post subject:  Re: Kinect 2 camera not working, Help appreciated

Hi Greenlaw, thanks for the input, but it's actaully a new build.
I am using a 6 core 3.50 Ghz processor, with 8GB ram and a geforce GTX 1050 ti graphics card.
It should easily run at least one kinect camera.

As I mentioned, I managed to actually get the machine to open ipirecorder with the camera, but the frame rate stays at 0, and it constantly seems to be 'installing new hardware'

I followed the suggestions from the link provided about support for usb, moved the usb card to the graphics slot I have spare, but still the same.
It is using the Renesas electronics drivers, which are apparently supported for kinect

Author:  SecondHarvest [ Tue Nov 29, 2016 6:25 am ]
Post subject:  Re: Kinect 2 camera not working, Help appreciated

I have made a video showing how it is running right now, using the kinect monitor, you can see it running reasonably well, but then resetting every 5 seconds.

Here is the video

https://www.youtube.com/watch?v=iJz6_vKUMPA

Author:  Greenlaw [ Tue Nov 29, 2016 9:09 am ]
Post subject:  Re: Kinect 2 camera not working, Help appreciated

Oh, yeah, that should work. Sorry, I must have misread.

Have you tried removing all the iPi files and re-installing? Maybe some component got corrupted or installed improperly?

Author:  SecondHarvest [ Tue Nov 29, 2016 10:37 am ]
Post subject:  Re: Kinect 2 camera not working, Help appreciated

Yes, I have tried reinstalling. but I suspect I have worked out the problem (I hope).
I think the issue I have, is that I have been trying usb 3.0 pci cards, instead of 3.1
If it is that, then I'm pretty annoyed, because the kinect configuration tool actually says no usb 3.0 ports
The microsoft support page actually says "please ensure that it is a Windows 8 compliant device and that it supports Gen-2"
I'm assuming it means 3.1

I have ordered a 3.1 usb from ebay, which will arrive next Monday, so I will post back results then.

Author:  Greenlaw [ Tue Nov 29, 2016 11:05 am ]
Post subject:  Re: Kinect 2 camera not working, Help appreciated

Hmm...let me know if that works for you. If it does, it might possibly mean I can use my render boxes after all.

BTW, the Configuration Tool on my tablet gives me an error for the USB, but in my case it simply says it doesn't recognize it. (I think the Wacom Cintiq Companion 2 has an Intel USB 3.0 controller.) Regardless, it still works at full rate. I know that doesn't help you but just putting it out there in case this happens with your new card.

Author:  vmaslov [ Wed Nov 30, 2016 11:26 am ]
Post subject:  Re: Kinect 2 camera not working, Help appreciated

SecondHarvest wrote:
It is using the Renesas electronics drivers, which are apparently supported for kinect

As seen in your video, you've actually got VIA USB 3.0 chipset, not Renesas/NEC.

SecondHarvest wrote:
The microsoft support page actually says "please ensure that it is a Windows 8 compliant device and that it supports Gen-2"
I'm assuming it means 3.1

I suppose they actually mean "USB 3.0 with support for PCI Express Gen 2". That means that they need the full speed of USB 3.0 spec, which is not supported by PCI Express 1.0.

Page 1 of 3 All times are UTC - 8 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/