Change font size
It is currently Mon Dec 10, 2018 8:11 pm


Post a new topicPost a reply Page 1 of 4   [ 31 posts ]
Go to page 1, 2, 3, 4  Next
Author Message
 Post subject: Kinect v2 desync?
PostPosted: Tue Jul 17, 2018 4:25 am 

Joined: Tue Jul 17, 2018 4:01 am
Posts: 15
Hello everyone!

I need a little help with a weird situation. I have two Kinectv2 cameras and two computers.
-Master computer is a PC (cpu i7 4770, Nvidia 1070, Asrock z87 extreme 4 motherboard)
-Slave computer is a Laptop (Asus Q550LF cpu i7 4500U)

Very often when I am recording and try to track, the depth information timeline per kinect camera seems to be out of sync. One camera is either behind or before the other camera in terms of timeline. (I attached a picture "difference.png") As the picture show I have a big difference. What is the problem? Can somebody help me with this? These computers not the newest but they should be powerful enough.
Thanks for the help guys!

Attachment:
difference.PNG
difference.PNG [ 606.94 KiB | Viewed 825 times ]


Top
 Profile  
 
 Post subject: Re: Kinect v2 desync?
PostPosted: Wed Jul 18, 2018 12:41 am 
iPi Soft

Joined: Wed Jan 11, 2012 6:12 am
Posts: 2041
Location: Moscow, Russia
Hi
Do you have stable 30 fps at both computers while recording?
Please make screenshots with video info of individual recordings (PC and laptop) from that distributed recording (or another with the same issue). Open each video in Recorder, click Video Info button in toolbar and expand 'track #' items to show the stats.


Top
 Profile  
 
 Post subject: Re: Kinect v2 desync?
PostPosted: Wed Jul 18, 2018 1:17 am 

Joined: Tue Jul 17, 2018 4:01 am
Posts: 15
Hello!

I opened all track information under the video info section and i made a screenshot for you. I see the delay from the 3rd second.


Attachment:
File comment: video info
data.png
data.png [ 152.67 KiB | Viewed 808 times ]



Attachment:
File comment: difference_timeline
delay.PNG
delay.PNG [ 643.97 KiB | Viewed 808 times ]


Top
 Profile  
 
 Post subject: Re: Kinect v2 desync?
PostPosted: Wed Jul 18, 2018 1:30 am 
iPi Soft

Joined: Wed Jan 11, 2012 6:12 am
Posts: 2041
Location: Moscow, Russia
I see there are some issues with first recording - a few frame gaps and bad frames, although not seeming critical.
Can you please provide similar screenshots for individual recordings before merging into one? That's what I requested actually.


Top
 Profile  
 
 Post subject: Re: Kinect v2 desync?
PostPosted: Wed Jul 18, 2018 2:25 am 

Joined: Tue Jul 17, 2018 4:01 am
Posts: 15
ohh okay sorry for the misunderstanding. Here are the individual screenshots:

Attachment:
File comment: master
data_master.png
data_master.png [ 66.27 KiB | Viewed 805 times ]


Attachment:
File comment: slave
data_slave.png
data_slave.png [ 51.87 KiB | Viewed 805 times ]


Top
 Profile  
 
 Post subject: Re: Kinect v2 desync?
PostPosted: Wed Jul 18, 2018 4:47 am 

Joined: Thu Sep 04, 2014 9:47 am
Posts: 878
Location: Florida USA
...

Maybe check that both computers Power setting is on High Performance?

Looks like the Laptop is running better than the Desktop.

Seems that would be the other way around.

Also check that your graphics card is set to prefer High Performance from its settings, although the recorder can run as low as 2G of a CPU and graphics cards aren't primary, but if in the machine, it recognizes them first, it should be set for Studio tracking as well.

Info. here: http://docs.ipisoft.com/Maximizing_GPU_ ... cap_Studio

...


Top
 Profile  
 
 Post subject: Re: Kinect v2 desync?
PostPosted: Wed Jul 18, 2018 5:52 am 

Joined: Tue Jul 17, 2018 4:01 am
Posts: 15
I thought the same, when i am recording i use my computers in high performance mode. Sadly it doesn't help.


Top
 Profile  
 
 Post subject: Re: Kinect v2 desync?
PostPosted: Wed Jul 18, 2018 5:58 am 

Joined: Thu Sep 04, 2014 9:47 am
Posts: 878
Location: Florida USA
...

Ok, was worth checking.

Seems if was a software issue, many others would be reporting it in the forum by now.

Is this the first time you tried a Kinect v2 on both machines in Distributed recording mode?

...


Top
 Profile  
 
 Post subject: Re: Kinect v2 desync?
PostPosted: Wed Jul 18, 2018 6:10 am 

Joined: Tue Jul 17, 2018 4:01 am
Posts: 15
I used iPi 3.6 or something similar version under the trial time with 2 kinect but i cannot recognize any issues before. Now when i try to make faster animations i just realized this problem when my body parts fly away.


Last edited by Zatesz on Wed Jul 18, 2018 6:46 am, edited 2 times in total.

Top
 Profile  
 
 Post subject: Re: Kinect v2 desync?
PostPosted: Wed Jul 18, 2018 6:19 am 

Joined: Thu Sep 04, 2014 9:47 am
Posts: 878
Location: Florida USA
...

Yeah, with Kinects you can't move extremely fast, should be able to move at a slower dance/fighting motion speed though, but the out of sync will cause the problem mostly for the trackers.

May be an issue within the software, I will let iPi continue the research into this, I was just trying some basic troubleshooting that may have helped, but if was working fine in v3, you would think would in v4.

One other thing, do you have only v4 of the Recorder and Studio installed on the Master machine? If you still have v3 installed as a separate program, uninstall it, or if you have already, disregard this.

Hope you get it working as it should soon.

Good Luck!

...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 4   [ 31 posts ]
Go to page 1, 2, 3, 4  Next


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron


Powered by phpBB® Forum Software © phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net