Change font size
It is currently Mon Jul 23, 2018 4:35 am


Post a new topicPost a reply Page 1 of 1   [ 4 posts ]
Author Message
 Post subject: Issue with 2 kinect 1
PostPosted: Fri Jun 29, 2018 10:32 am 

Joined: Fri Jun 29, 2018 10:11 am
Posts: 2
Hi,

I have some issue to use Ipi Recorder 2 with 2 kinect 1. I try independently each of them and it's working perfectly but when I try to use them in the same time, it's working first and then there is a red message saying ''the sensor is initializing, please wait'', it leave and come back all the same, and when I launch the setup the video stop in both part.
For information, I'm using a Asus rog with 2 USB 2 and 1 USB 3. I'm using Kinect for Windows SDK v.8 + Open NI Windows 64 22033.
I precise too that my material (computer + kinect adapators) is americain and I'm using it in Europe, so everything go throught adaptators.

Is someone can help me ?

Thank you a lot

Marie


Top
 Profile  
 
PostPosted: Sat Jun 30, 2018 12:28 am 
iPi Soft

Joined: Wed Jan 11, 2012 6:12 am
Posts: 2004
Location: Moscow, Russia
Hi
First, check various USB ports for connecting Kinect devices. Each one should be connected to a separate USB controller. Most probably, connecting one to USB 2.0 port and another to USB 3.0 is the way to go. However, depending on actual physical implementation of USB controllers in your laptop it may be not possible to get both Kinects working at once. It's much simpler with desktop PCs when you can just add an extension card with additional USB controller.
Also there may be a conflict caused by having Microsoft Kinect SDK and Open NI installed simultaneously. Try uninstalling OpenNI and all things containing "Kinect" in their names besides Kinect SDK.


Top
 Profile  
 
PostPosted: Thu Jul 12, 2018 7:59 am 

Joined: Fri Jun 29, 2018 10:11 am
Posts: 2
Thank you for your answer.

I try all the combinaison of USB ports but it's the same. I think my computer got only 1 USB controller for all of the USB ports, is that possible ? Because when I plug the 2 kinects, my computer start crashing, and I ear the sound of connect/disconnect several times + the informations inside the Device manager / Universal serial bus controller don't stop to change.
My laptop don't have a ExpressCard card slot unfortunatly, is there another way to add a USB controller ?

I uninstall Open NI, but it changes nothing. Should I have to uninstall all the ''Kinect for Windows'' drivers (picture 3) and only keep the ''Kinect SDK'' one ?

And everything still ok when it's only about 1 kinect.


Attachments:
Screenshot (8).png
Screenshot (8).png [ 485.1 KiB | Viewed 54 times ]
Screenshot (7).png
Screenshot (7).png [ 285.33 KiB | Viewed 54 times ]
Screenshot (6).png
Screenshot (6).png [ 409.86 KiB | Viewed 54 times ]
Top
 Profile  
 
PostPosted: Thu Jul 12, 2018 9:51 am 
iPi Soft

Joined: Wed Jan 11, 2012 6:12 am
Posts: 2004
Location: Moscow, Russia
I recall now that Kinect v1 has known issue with recent Intel chipsets 8x series and later. Multiple sensors do not work properly when connected to USB ports of such chipsets. Here is the discussion of the issue
https://social.msdn.microsoft.com/Forum ... =kinectsdk
So if your laptop is based on one of those chipsets than you're out of luck. And there's no way to add USB controller to modern laptops, ExpressCard port is outdated tech not present nowadays.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 4 posts ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB® Forum Software © phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net